WordPress Tutorials

Should You Install Plugins Not Tested With Your WordPress Version?

Often many WordPress users are concerned about the warning that a Plugins Not Tested With Your WordPress Version. Should you install that plugin not tested with your WordPress version ? or find another plugin? In this article, we will discuss when it is okay to install plugins not tested with your version of WordPress? What does it mean and what you can do?

When you install a plugin from WordPress admin area, you may see a warning that a plugin is not been tested with your version of WordPress.

plugin compatability warning

Why Are Plugins Not Tested?

The official WordPress plugin repository is the largest collection of free and open source WordPress plugins. When submitting the plugin, authors are required to submit a “readme” file with their plugins. This readme file is then used by the plugin directory to generate plugin page.

The readme file contains the “tested up to” tag which is used to display the information. Plugin authors are expected to keep this information up to date.

This means that with each release of WordPress, plugin authors should test their plugins and update the readme files for their plugins.

Many plugin authors don’t update their readme files at all even when they test their plugin with the latest version.

Remember that these plugins are free, and you are not paying authors to download and use them. Plugin authors feel less inclined to update the readme file with each release. They are usually busy with their full-time jobs and paid development projects.

Big Question, Should You Install These Plugins

Answer Is Yes, Just because a plugin author didn’t update their readme file doesn’t mean that they have not tested their plugin or that the plugin doesn’t work with the latest version of WordPress.

On the other hand, if a plugin has not been updated for more than two years, then this means that most probably the plugin has been abandoned. In that case, you should not install the plugin.

It would be interesting to note that many plugins that haven’t been updated for more than two years actually still work very well. However, you should install them at your own risk and If you are using eCommerce on your website or collect sensitive Information like credit card details we will not recommend to Install plugins which are not updated in last two Years and you should try other options or you can always reach us as we are always more than happy to help our users.

How Can You Help WordPress Community?

You can install the plugin on your WordPress site and test it out. If it works as expected, then come back to plugin’s page. Log in with your WordPress.org username and password. Next, scroll down to the bottom of the page where you will see the compatibility section.

vote plugin compatibility

Simply choose your WordPress version, plugin version, and then click on the Works button. By doing that, you are letting other users know that you have tested the plugin, and it works as promised.

You can also contact the plugin author and kindly ask them to update their plugin’s readme file.

Recap: Should You Install Plugins Not Tested With Your WordPress Version 

  • Yes, you can Install those plugins. They are safe
  • When submitting the plugin to WordPress Directory, authors are required to submit a “readme” file.
  • Many plugin authors don’t update their readme files.
  • If a plugin has not been updated for more than two years, Avoid it.
  • You Can Help WordPress Community.
  • By Testing Non-Tested Plugins and Vote if it works or not

Any Questions? Leave Us a Comment and as always we will be more than happy to help our Readers. You can use the buttons below to share it with your friends.

Show More

Related Articles

Close
Close